Fix Flashing Save And Publish Button In WordPress 2.5.1

Since I upgraded my blog from WordPress 2.5 to WordPress 2.5.1, life has not really been the same. Even though I reported the upgrade as been sucessful I discovered much later that something was really wrong.

The SAVE and PUBLISH buttons on the admin dashboard flashes whenver I try to write a post (there were other issues, but that was easily identifiable). After going through posts by others that have similar issues in the WordPress forum, I was more perplexed than helped. As at one hour ago before posting this, I was still confused on what the solution could be.

Finally, some few minutes ago, I came accross a post that I read before but did not understand. The 20th post gave a clue which was all the solution I need. The poster, Sam_a stated that anyone experiencing the problem should check to ensure that he actually uploaded the new wp-settings.php file that was included in the WordPress 2.5.1 folder.

When I checked, I discovered that I was having the old wp-settings.php file from WordPress 2.5 So, I renamed that file and then uploaded the new file from WordPress 2.5.1 folder that I have on my desktop. After doing that, I have not experienced the blinking SAVE and PUBLISH button again. For now the admin dashboard is more stable than it was before and hopefully, there will not be any other issue.

If you had similar issue, I suggest you try this solution. I am still at a loss why I could not do an automatic upgrade, if you have a clue, please drop a note in the comment section. Thanks.

6 Comments Comments For This Post I'd Love to Hear Yours!

  1. Brian says:

    WOW! It’s almost *sickening* how well that worked! That flashing “Save” button has been driving me crazy for weeks. Then, one luckily-worded Google query (“flashing save wordpress”) and all my troubles are over. Thanks a million!

  2. NaijaEcash says:

    [re=234]Brian[/re]:
    Thanks Brian. I am really delighted to know that my little post was useful to at least one person. However, the credit goes to the guys at the WordPress forum who posted the solution free. I was only a messenger in delivering the information to you.
    Thanks for visiting my blog.

  3. albir says:

    Since I thought I was the only one that had this weird problem, I didn’t tried to solve it, till I googleit and found your solution.

    thx

    😛

  4. NaijaEcash says:

    [re=271]albir[/re]:
    It is my pleasure being a part of the solution to the nagging problem. Thanks for visiting.

  5. carluew says:

    I found this quite useful. Thanks for the tips.

    http://www.creditmenow.info

  6. rd says:

    I encountered the same error, but the reason why my buttons where flashing, was because of a simple line in my wp-config.php:

    define('AUTOSAVE_INTERVAL', false);

    I deleted this specific line and everything went fine again.

Leave a Comment Here's Your Chance to Be Heard!

CommentLuv badge